Back to overview
Downtime

Miami Outage

May 28, 2026 at 3:04pm UTC
Affected services
Miami
Billing Portal
Website
VPS Panel

Updated
May 28, 2026 at 5:43pm UTC

Technician on-site was scheduled for today around 20:00 EST

Updated
May 28, 2026 at 3:50pm UTC

The issue was caused by a cross-connection cable failure. It'll be replaced as soon as we get a tech on-site.

Created
May 28, 2026 at 3:04pm UTC

We are currently investigating this incident.