Back to overview
Maintenance

Miami Network Maintenance

Aug 28 at 11:00am GMT-5  –  Aug 30 at 01:33pm GMT-5
Affected services
Miami
Billing Portal
Website
VPS Panel

Resolved
Aug 30 at 01:33pm GMT-5

Miami is back

Updated
Aug 30 at 11:33am GMT-5

Upstream rerouting is still in progress. Network performance in Miami remains degraded.
We will provide updates as the situation stabilizes.

Updated
Aug 29 at 10:24am GMT-5

Scheduled maintenance is currently in progress. We will provide updates as necessary.

Created
Aug 28 at 11:00am GMT-5

We will be performing emergency maintenance at our Miami (MIA) location to improve network capacity and stability.

Start: August 28, 2025 – 16:00 UTC

End: September 1, 2025 – 16:00 UTC